WPF With Blazor

Post here messages if you have any problems with working of Enigma Protector
Post Reply
Belloski
Posts: 4
Joined: Sat Mar 09, 2024 5:08 am

WPF With Blazor

Post by Belloski »

i have an application that uses Hybrid Blazor and WPF, i followed the tutorials to protect the files and one problem is that this projects uses the wwwroot folder that seems to not work if it is not extracted at runtime from virtual box, can i run the app without extracting this folder, because the application says the the folder does not exist when running it but when i put the extract to disk always, it works.
im using the demo version just to test before buying.
Enigma
Site Admin
Posts: 2943
Joined: Wed Aug 20, 2008 2:24 pm

Re: WPF With Blazor

Post by Enigma »

Hi, I recommend you to try to enable the following options in Virtual Box - Options:
1. Share virtual system to child processes
2. Share to processes of any platform.

If above does not help, send us non packed files (together with protect files), so we can reproduce problem on development computers and investigate what is happening.
Belloski
Posts: 4
Joined: Sat Mar 09, 2024 5:08 am

Re: WPF With Blazor

Post by Belloski »

i tried what you told me but its the same i'll send the test project
when packed the app will not work unless you use the write files to disk always to all the files in wwwroot folder
also u need to publish the file or don't add test.App.staticwebassets.runtime.json file or it will use the static files that are already extracted in the project
Attachments
test.zip
(8.38 KiB) Downloaded 15 times
Enigma
Site Admin
Posts: 2943
Joined: Wed Aug 20, 2008 2:24 pm

Re: WPF With Blazor

Post by Enigma »

Hi, just tried what you described, using Enigma Protector x64 (version 7.50, which does not have official DEMO version):
- remove test.App.staticwebassets.runtime.json
- add all application files, all .dlls and wwwroot folder into Virtual Box - Default Folder
- protect the file, keep it alone, run - everything works perfectly, no errors that folder is not found.

Please send us a message at support@enigmaprotector.com, we will give you recent DEMO version for testing.
Belloski
Posts: 4
Joined: Sat Mar 09, 2024 5:08 am

Re: WPF With Blazor

Post by Belloski »

ok, thanks for replying I will send you an email now to test that version.
Belloski
Posts: 4
Joined: Sat Mar 09, 2024 5:08 am

Re: WPF With Blazor

Post by Belloski »

im still waiting for a response :?:
Enigma
Site Admin
Posts: 2943
Joined: Wed Aug 20, 2008 2:24 pm

Re: WPF With Blazor

Post by Enigma »

Sorry for the delay, just sent it.
Post Reply