CreateRemoteThread

Post here messages if you have any problems with working of Enigma Protector
Post Reply
BigMeme
Posts: 1
Joined: Sat Apr 02, 2016 6:21 pm

CreateRemoteThread

Post by BigMeme » Sat Apr 02, 2016 6:35 pm

I've been having an issue where a C++ program protected with the demo version of Enigma Protector (4.40) crashes when I call CreateRemoteThread. I have Redirect WinAPI functions and Emulate WinAPI functions both disabled. I only get the crash when I compile in visual studio 2012 using Common Language RunTime Support (/clr). The exact same code works when that's disabled, but in the project where I have that enabled (I'm using it so I can use windows forms), it crashes when I call CreateRemoteThread. I've double checked that /clr is the problem by taking the old project that didn't crash before when protected with Enigma Protector and just enabled Common Language RunTime Support and it crashed when ran with Enigma Protector. Is there a solution to this or should I just not use /clr and not use Windows Forms and make the GUI with some other library?

ds-cs
Posts: 6
Joined: Tue Nov 10, 2015 4:34 pm

Re: CreateRemoteThread

Post by ds-cs » Mon Aug 01, 2016 8:59 am

I have the same Problems without using Windows forms. The Problem is createremotethread! Using Enigma Version 5.4.

Enigma
Site Admin
Posts: 2388
Joined: Wed Aug 20, 2008 2:24 pm

Re: CreateRemoteThread

Post by Enigma » Wed Aug 03, 2016 10:38 am

Are you using dll/code injection technology in your application?

ds-cs
Posts: 6
Joined: Tue Nov 10, 2015 4:34 pm

Re: CreateRemoteThread

Post by ds-cs » Sun Aug 07, 2016 11:33 am

yes. i fixed it with function selecting from virtuell box.

Enigma
Site Admin
Posts: 2388
Joined: Wed Aug 20, 2008 2:24 pm

Re: CreateRemoteThread

Post by Enigma » Wed Aug 10, 2016 5:10 pm

ok. But also same behavior may cause settings on the Protection Features - Import Protection panel.

Post Reply