x64 API calls fail

Post here messages if you have any problems with working of Enigma Protector
Post Reply
EddieT
Posts: 9
Joined: Fri Sep 28, 2012 8:08 pm

x64 API calls fail

Post by EddieT »

Hi
I have x86 and x64 executables compiled from the same code.

Both are protected as time-limited trials using Enigma x86 and x64 schemas from the same source scheme.

The x86 version works fine. The x64 version will not run due to enigma_ide.dll not found.

The x64 exe is protected successfully but is still looking for the debug dll?

What's happening? I'm using the latest Enigma versions.
Enigma
Site Admin
Posts: 2992
Joined: Wed Aug 20, 2008 2:24 pm

Re: x64 API calls fail

Post by Enigma »

Hi Eddie, can you please let me know what programming language you are using? What Enigma SDK you are using?

x64 version uses enigma_ide64.dll, while x86 uses enigma_ide.dll, this is the difference.
EddieT
Posts: 9
Joined: Fri Sep 28, 2012 8:08 pm

Re: x64 API calls fail

Post by EddieT »

Hi,
The problem is that after my 64-bit app is successfully protected, it continues to look for enigma_ide64.dll

The protections is successful, the logs report no errors, the .exe file size has doubled from the unprotected file.

And it runs fine if I include enigma_ide64.dll in the install folder, but the executable is not actually implementing the calls to check trial days, it's using the DLL stubs and returning 0 for everything.

The x86 version of the same executable works fine.

Any ideas?
EddieT
Posts: 9
Joined: Fri Sep 28, 2012 8:08 pm

Re: x64 API calls fail

Post by EddieT »

This application is VB compiled with Visual Studio 2019.
EddieT
Posts: 9
Joined: Fri Sep 28, 2012 8:08 pm

Re: x64 API calls fail

Post by EddieT »

Hello again,
I've sorted this. The cause was indeed that I was using the x86 api dll and not the x64.

Thanks for your help.

Eddie
Enigma
Site Admin
Posts: 2992
Joined: Wed Aug 20, 2008 2:24 pm

Re: x64 API calls fail

Post by Enigma »

Hi Eddie, thanks you for confirmation!
Post Reply