problems running on Windows 10 S

Issues related to Enigma Virtual Box
Post Reply
zkrige
Posts: 6
Joined: Mon Apr 29, 2019 12:47 pm

problems running on Windows 10 S

Post by zkrige » Mon Apr 29, 2019 12:49 pm

Apps bundled into enigmaVB do not run/extract properly on windows 10 S.

Enigma
Site Admin
Posts: 2516
Joined: Wed Aug 20, 2008 2:24 pm

Re: problems running on Windows 10 S

Post by Enigma » Mon Apr 29, 2019 2:26 pm

Hi, as far as I know, Windows 10S allows application installation from Windows Store only.
Do you upload bundled application to Windows Store, then install them?

zkrige
Posts: 6
Joined: Mon Apr 29, 2019 12:47 pm

Re: problems running on Windows 10 S

Post by zkrige » Tue Apr 30, 2019 5:14 am

Thank you so much for the prompt reply.

When we upload to the Windows store we get a generic warning that the app failed their testing. They provide some steps to test - https://docs.microsoft.com/en-us/window ... -windows-s

I've installed the audit policy which only reports any failures, but allows the app to run. The audit policy fails with the following message

Code Integrity determined that a process (\Device\HarddiskVolume4\Program Files (x86)\Company\My App.exe) attempted to load \Device\HarddiskVolume4\Users\Zayin\AppData\Local\Temp\evb24BB.tmp that did not meet the Enterprise signing level requirements or violated code integrity policy. However, due to code integrity auditing policy, the image was allowed to load.

So it seems the evb tmp files need to somehow be signed. We create our installer using WIX and sign the WIX installer with our p12 using signtool

Enigma
Site Admin
Posts: 2516
Joined: Wed Aug 20, 2008 2:24 pm

Re: problems running on Windows 10 S

Post by Enigma » Tue Apr 30, 2019 12:02 pm

EVB runs .tmp files only when virtual exe file is being executed.
Please exclude all .exe files from Virtual Box and try again, hope it will be working now.

zkrige
Posts: 6
Joined: Mon Apr 29, 2019 12:47 pm

Re: problems running on Windows 10 S

Post by zkrige » Tue Apr 30, 2019 12:06 pm

Thank you for the explanation. This kinda makes sense.

Our app is a NWJS app. We exclude our main exe, but the other exe's probably need to be there for the app to execute properly.

Is there any way to mitigate this? Should we sign all the exes? Can you suggest some other solution?

Enigma
Site Admin
Posts: 2516
Joined: Wed Aug 20, 2008 2:24 pm

Re: problems running on Windows 10 S

Post by Enigma » Tue Apr 30, 2019 12:22 pm

Unfortunately, there is no way to sign these tmp files. The only way - exclude all exe files from Virtual Box.

zkrige
Posts: 6
Joined: Mon Apr 29, 2019 12:47 pm

Re: problems running on Windows 10 S

Post by zkrige » Tue Apr 30, 2019 12:31 pm

ok thank you very much for your help. I'll dig around and see what we can do

zkrige
Posts: 6
Joined: Mon Apr 29, 2019 12:47 pm

Re: problems running on Windows 10 S

Post by zkrige » Thu May 02, 2019 1:27 pm

I have excluded ALL exe files, yet the issue remains. I can send you the .evb and raw files if that will help?

Enigma
Site Admin
Posts: 2516
Joined: Wed Aug 20, 2008 2:24 pm

Re: problems running on Windows 10 S

Post by Enigma » Mon May 06, 2019 6:34 am

Can you please also try to disable the option "Map executable files with temporary file"?

zkrige
Posts: 6
Joined: Mon Apr 29, 2019 12:47 pm

Re: problems running on Windows 10 S

Post by zkrige » Mon May 06, 2019 8:43 am

I have tried that, but then the app doesn't start up

Post Reply