Any questions? Ask us: support@enigmaprotector.com

AutoIt protection

Post here any topics that related to Enigma Protector, its functionality, your misunderstanding, offers to improvements etc etc etc

Re: AutoIt protection

Postby newuser » Thu Feb 13, 2014 10:32 am

newuser
 
Posts: 49
Joined: Tue Apr 13, 2010 5:43 pm

Re: AutoIt protection

Postby D3Dx9 » Thu Feb 13, 2014 2:07 pm

Here's the little gif :)
http://s7.postimg.org/6t3dpx73t/test.gif

(I love theese gif videos :) Looks cool, easy to capture and quite small)
Deobfuscated:
Code: Select all
MsgBox(0x1000, "Test", "Final test.")
D3Dx9
 
Posts: 15
Joined: Sun Feb 09, 2014 5:25 pm

Re: AutoIt protection

Postby newuser » Thu Feb 13, 2014 3:25 pm

Alright, maybe something in my system conflict with the decompiler, maybe due to all the giveawayoftheday softwares I installed recently. Sorry. :shock:

Anyway, heres the protected file using the method mention in that particular thread(might not be very accurate since I just try/error cause I dont really understand it).

Protected

BTW, how do you get the code, its not even close to the original code I use? :?:
Last edited by newuser on Thu Feb 13, 2014 8:34 pm, edited 1 time in total.
newuser
 
Posts: 49
Joined: Tue Apr 13, 2010 5:43 pm

Re: AutoIt protection

Postby D3Dx9 » Thu Feb 13, 2014 8:07 pm

D3Dx9
 
Posts: 15
Joined: Sun Feb 09, 2014 5:25 pm

Re: AutoIt protection

Postby newuser » Thu Feb 13, 2014 8:38 pm

From one of your previous gif file, I saw that we are using the same decompiler version.
But I cant seem to make it work against the test files I created using enigma protector, maybe the new decompiler version doesn't work properly on my system. :(

BTW, is your test system setup running in vm, or is actual desktop? :?:
newuser
 
Posts: 49
Joined: Tue Apr 13, 2010 5:43 pm

Re: AutoIt protection

Postby D3Dx9 » Fri Feb 14, 2014 12:13 am

That's my actual system, Windows 8.1 :)
D3Dx9
 
Posts: 15
Joined: Sun Feb 09, 2014 5:25 pm

Re: AutoIt protection

Postby newuser » Fri Feb 14, 2014 7:42 am

Well, I dont have Win8 and I even tested in vm windows xp, and the decompiler still didnt work on those files. :?:

Maybe someone else with win8 or winxp can have a go at the test files just to confirm whether its my system fault or win8 is a heaven for decompilers test setup. :?:
newuser
 
Posts: 49
Joined: Tue Apr 13, 2010 5:43 pm

Re: AutoIt protection

Postby D3Dx9 » Fri Feb 14, 2014 8:13 am

Lol, I tested it on Windows XP - VM, But it didn't succeed. LOL, interesting... :)
D3Dx9
 
Posts: 15
Joined: Sun Feb 09, 2014 5:25 pm

Re: AutoIt protection

Postby newuser » Fri Feb 14, 2014 9:36 am

Oh boy, the culprit is windows xp. :shock:

Could you test it on windows 7 too, if you have it since I dont have windows 7.
Thank you.
newuser
 
Posts: 49
Joined: Tue Apr 13, 2010 5:43 pm

Re: AutoIt protection

Postby D3Dx9 » Sat Feb 15, 2014 11:03 am

It still succeed :) It was on an x64 Win7 - VBox :)

GIF:
http://s29.postimg.org/uon1m4v1h/test.gif
D3Dx9
 
Posts: 15
Joined: Sun Feb 09, 2014 5:25 pm

PreviousNext

Return to Basic

Who is online

Users browsing this forum: No registered users and 10 guests

cron