Any questions? Ask us: support@enigmaprotector.com

Problem after code-signing a protected executable

Post here messages if you have any problems with working of Enigma Protector

Problem after code-signing a protected executable

Postby domador » Tue Sep 20, 2016 7:15 pm

Hello. I get an error message when I try to run a protected executable that I've also code-signed. I get the following error message:

----

Runtime Error
Press OK to Continue
Press Cancel to Quit.

Please report what caused this error
along with the information below.

Common\Loaders\LoaderWindows.cpp: 119
Failure Condition: 0
Executable is corrupt!

----

I developed the executable using Xojo 2014 Release 2.1.
I then protect it with the Enigma Protector 5.40 32-bit.
So far, so good. The executable runs fine.
Then I sign it with my StartCom certificate using the StartCom tool version 3.0.0.4 (startcomtool.exe).
Afterward when I try to run the program, I get the error message.

Any ideas for possible solutions?
domador
 
Posts: 12
Joined: Fri Mar 25, 2011 8:08 pm

Re: Problem after code-signing a protected executable

Postby Enigma » Wed Sep 21, 2016 7:46 am

Hi, unfortunately, this is difficult to say what could be wrong there.

But you could try these two ways:

1. Digitally sign the unprotected exe file, if it will not work, then I think you should ask for solution of Xojo developers.
2. Try to use signtool.exe instead of startcomtool.exe
Enigma
Site Admin
 
Posts: 2199
Joined: Wed Aug 20, 2008 2:24 pm

Re: Problem after code-signing a protected executable

Postby domador » Wed Sep 21, 2016 5:42 pm

1. I am able to sign the unprotected file with no problems. When I run the signed, unprotected file I get an error message about a function that could not be resolved in enigma_ide.dll. However, that is to be expected, since the executable would need to be protected with EP for those function references to be resolved. I've also tried code-signing a different executable for a different program I've made with Xojo (one that doesn't use EP) and it works fine.

2. I tried using signtool.exe and ran into the same issue as with the StartCom tool.

There must be something about the way Enigma Protector and the code-signing tools each alter the executable that conflicts with each other. For now, I'll protect my app but leave it unsigned. Hopefully in the future a solution can be found.
domador
 
Posts: 12
Joined: Fri Mar 25, 2011 8:08 pm

Re: Problem after code-signing a protected executable

Postby chris_s » Thu Nov 03, 2016 5:54 pm

I am in the process of getting the ability to "code-sign" my code. Will I be able to sign an executable that is protected with Enigma or will that be a problem?
chris_s
 
Posts: 8
Joined: Tue Oct 18, 2016 7:44 pm

Re: Problem after code-signing a protected executable

Postby Enigma » Fri Nov 04, 2016 5:10 pm

chris_s wrote:I am in the process of getting the ability to "code-sign" my code. Will I be able to sign an executable that is protected with Enigma or will that be a problem?


You will be able to sign it, there should be no any problem.
Enigma
Site Admin
 
Posts: 2199
Joined: Wed Aug 20, 2008 2:24 pm


Return to Problems

Who is online

Users browsing this forum: No registered users and 15 guests