Downgrading from 1.63 to 1.54

Post here messages if you have any problems with working of Enigma Protector
Post Reply
iaanus
Posts: 24
Joined: Tue Feb 03, 2009 12:08 pm

Downgrading from 1.63 to 1.54

Post by iaanus » Wed Feb 18, 2009 11:14 pm

Hi,

I'm having a very hard time with Enigma 1.63. The protected application sees some literal strings corrupted and crashes. I have tried different settings in Enigma in the last three hours and unfortunately my time budget is running low... I am very sorry but I have to revert to the latest properly working version of Enigma which is (for me, at least) v1.54.

I uninstalled v1.63 and erased all recognizable registry entries, then installed v1.54. However, when I run v1.54 the "Unlock..." menu entry appears grey and it won't let me register. The app seems to be locked in [DEMO] mode. Is there something special I should to downgrade to v1.54?

Thanks in advance,

iaanus
Posts: 24
Joined: Tue Feb 03, 2009 12:08 pm

Re: Downgrading from 1.63 to 1.54

Post by iaanus » Thu Feb 19, 2009 10:30 am

I installed 1.54 on a clean machine an still I see the "Unlock..." menu gray. Is there a time bomb or something?

I have more news about the problems with 1.63, though. It may happen that a protected executable has no problems, but if it has problems they are reproducible 100%. Unfortunately, I cannot debug to be more precise... because it's protected! In at least one case, I had a protected executable running fine on XP, but getting corrupted strings on Vista. If I executed the exe on Vista in "XP compatibility mode" it was fine. So there seems to be something in Vista that interacts with the problem.

The exe was built in C++ with Visual Studio 2005 with all optimizations enabled.

Enigma
Site Admin
Posts: 2557
Joined: Wed Aug 20, 2008 2:24 pm

Re: Downgrading from 1.63 to 1.54

Post by Enigma » Thu Feb 19, 2009 10:49 am

Could you please send me (at support@enigmaprotector.com) your non protected file for the test (and describe in short what options are enabled in the project file).
Just for future, if you have any problems, if something does not work, do not spend your time, imediately send me non protected file and I promise that all the bugs will be fixed very soon!

Regarding 1.54 version, yes, full version has been deleted from the older link... please write me back at email and I will send you this link... But can advice you to use latest version.

iaanus
Posts: 24
Joined: Tue Feb 03, 2009 12:08 pm

Re: Downgrading from 1.63 to 1.54

Post by iaanus » Thu Feb 19, 2009 11:28 am

Enigma wrote:Could you please send me (at support@enigmaprotector.com) your non protected file for the test (and describe in short what options are enabled in the project file).
Just for future, if you have any problems, if something does not work, do not spend your time, imediately send me non protected file and I promise that all the bugs will be fixed very soon!
Unfortunately it's not that easy, because the program is quite big and requires several additional files, some of which I'm not allowed to distribute. However, if I can find a minimal set of files that reproduces the problem, I will send them to you. Thanks.

Enigma
Site Admin
Posts: 2557
Joined: Wed Aug 20, 2008 2:24 pm

Re: Downgrading from 1.63 to 1.54

Post by Enigma » Thu Feb 19, 2009 11:33 am

Ok, but may be in short you write me back what options are enabled in the project file? Maybe there is some incompatibilities that I can fix without main files...

Once again, please do spend your time on solving NOT yours errors, I'm here and ready to help/fix bug etc etc.

iaanus
Posts: 24
Joined: Tue Feb 03, 2009 12:08 pm

Re: Downgrading from 1.63 to 1.54

Post by iaanus » Thu Feb 19, 2009 1:52 pm

Good news. It turned out that it was my mistake after all. I was accessing a pointer to a string that had been freed. Somehow, by a very strange coincidence, this fact didn't create any problem to the unprotected exe, but was crashing the protected one.
I apologize for the noise. Problem solved.

Enigma
Site Admin
Posts: 2557
Joined: Wed Aug 20, 2008 2:24 pm

Re: Downgrading from 1.63 to 1.54

Post by Enigma » Thu Feb 19, 2009 6:48 pm

Ok, do not worry, glad that everything is working well now!

Post Reply