Any questions? Ask us: support@enigmaprotector.com

OCX Registration - Internal Protection Error

Post here messages if you have any problems with working of Enigma Protector

OCX Registration - Internal Protection Error

Postby josnav » Fri Aug 12, 2011 6:39 am

I'm very interested about buying your protection so I have downloaded Demo version.
I'm protecting my Visual Basic 6.0 app (native code) and ALL is ok. I love your app but I got an error. When I use Virtual Box, ALL is ok in my development PC (Windows 7 x64) my OCX, DLL are embebedded but when I try in different PC I got the classic Visual Basic OCX register error. No problem, I check box in Enigma to register OCX in Virtual Box. Then, I got Internal Protection error in ALL PCs (development PC,others, etc...)
So, how can I register OCX without Internal error?
josnav
 
Posts: 2
Joined: Fri Aug 12, 2011 6:22 am

Re: OCX Registration - Internal Protection Error

Postby Enigma » Fri Aug 12, 2011 7:14 am

Hi josnav, this kind of error may appear with the previous versions of Enigma Protector.

Just yesterday, we have release The Enigma Protector 3.0, the Virtual Box feature completely remade there, it is much stable now. Please try it, read more here:
viewtopic.php?f=7&t=1440

Also, do not forget to enable Registry Virtualization there, so all changes in registry (I mean OCX registration) performs on a virtual registry only (to avoid permissions problems if program will be run without administrator privileges).

If it still will not work, then please send us non protected example at support@enigmaprotector.com and we will test it out.
Enigma
Site Admin
 
Posts: 2126
Joined: Wed Aug 20, 2008 2:24 pm

Re: OCX Registration - Internal Protection Error

Postby josnav » Fri Aug 12, 2011 9:33 am

Trying to test 3.0 but I got an Invalid hardware ID error in your keygen when I put my Hardware ID generated by Enigma.
In 2.xx hardware ID was right, now is invalid. :?:
josnav
 
Posts: 2
Joined: Fri Aug 12, 2011 6:22 am

Re: OCX Registration - Internal Protection Error

Postby Enigma » Sun Aug 14, 2011 8:44 am

josnav wrote:Trying to test 3.0 but I got an Invalid hardware ID error in your keygen when I put my Hardware ID generated by Enigma.
In 2.xx hardware ID was right, now is invalid. :?:


I think you just did not save project file. When you open Enigma Protector, it re-opens previously opened/saved project file or create a new project. In your case, I seem, Enigma Protector just creates a new project and surely, Hardware Id for one project is not same for second project.

Simply save project file, and use it for generating of registration keys and protecting your file.
Enigma
Site Admin
 
Posts: 2126
Joined: Wed Aug 20, 2008 2:24 pm

Re: OCX Registration - Internal Protection Error

Postby nop123 » Sun Jun 21, 2015 9:00 am

josnav wrote:Trying to test 3.0 but I got an Invalid hardware ID error in your keygen when I put my Hardware ID generated by Enigma.
In 2.xx hardware ID was right, now is invalid. :?:


same here...ver 4.30
i allway get: Hardware ID is invalid
:o :o
nop123
 
Posts: 3
Joined: Sat Nov 29, 2014 1:42 pm


Return to Problems

Who is online

Users browsing this forum: ilya01 and 4 guests