Any questions? Ask us: support@enigmaprotector.com

Hide virtual file system on windows explorer

Issues related to Enigma Virtual Box

Hide virtual file system on windows explorer

Postby asdfasdf » Sun Feb 15, 2015 6:12 pm

Hi everybody.

I'm trying to create a single exe of my app containing all necessary dll by using enigma virtual box.

I create this exe and it works fine in other computers i checked, but when saving or opening files the virtual file system is visible on the openFileDialog that opens. For instance i have two folders inside the %DEFAULT FOLDER%. These folders are "imageformats" and "platforms". And when i try to save a file i can see them. I cannot save any files there of course because they are virtual but still this is something i'd rather not happening.

Apart from that it seems that the virtual file system creates the whole path all over. What i mean is that when this new exe is in my desktop (path C:\Users\User\Desktop) I can see two "User" folders in the explorer and inside any of these two "desktop" and so on (like in the attached pic).

I've tried setting the dll to hidden and uncheck the "share virtual system to child processes" options but nothing changes. I'll try creating a completely fictional directory like Z:\asdf\whatever and have my app searching there for libraries but is it sure that it will not become visible and that my app will still work?

Any other ideas on how to solve this?
You do not have the required permissions to view the files attached to this post.
asdfasdf
 
Posts: 1
Joined: Wed Feb 11, 2015 11:57 pm

Return to Enigma Virtual Box x86/x64

Who is online

Users browsing this forum: Google [Bot] and 13 guests