Any questions? Ask us: support@enigmaprotector.com

v.7.20 unregister components after Process

Issues related to Enigma Virtual Box

v.7.20 unregister components after Process

Postby gibra » Tue Nov 04, 2014 9:05 pm

First of all, I tell you that with the previous version 7.10 I have never had any problems and I'm successfully deploying my VS6 installer v.4.0 (http://nuke.vbcorner.net)

Using the latest version 7.20 happened to me a disaster. :cry:
I wanted to try with my application in which I use some OCX provided with VB6 (Windows Common Controls 6, etc.) And other third-party DLL and OCX (ComponentOne, DataDynamics, etc.).

So I simply added all the OCX / DLL under %DEFAULT_FOLDER% and set for each component the flag Register as ActiveX (COM) component without touching any other options, then run Process.
After this I have run the myapp_boxed.exe to try if this is start.

Today I restarted the same VBP project that I was studded with errors pointing that all components were no longer registered! :o

Because all resume his work, I had to 'repair' install VB6.0 EE and all suite components (ComponentOne, DataDynamics, etc.).

Frankly, I was thrilled! :?
What might be the situation?

Thank.

My system is:
Visual Basic 6.0 Enterprise Edition - SP6
Windows 7 64bit - SP1
gibra
 
Posts: 4
Joined: Tue Nov 04, 2014 8:10 pm

Re: v.7.20 unregister components after Process

Postby Alec » Thu Nov 06, 2014 10:41 am

Can you try to reproduce the bug ?
If the result will be the same please send us your executable with instructions to support@enigmaprotector.com
Alec
 
Posts: 86
Joined: Thu Feb 20, 2014 9:35 am

Re: v.7.20 unregister components after Process

Postby gibra » Thu Nov 06, 2014 1:51 pm

Alec wrote:Can you try to reproduce the bug ?

No, of course, because the problem isn't the executable generated by VirtualBox,
but the system where all attached components has been un-registered.


Now I removed 7.20 and reinstalled the 7.10 (which I have never had problems), when I have a little time I'll do the tests (of course on a virtual machine) because I really do not want to have to reinstall everything again.

I send you the project file EVB.

Now I remember that in the previous project (V7.10) there are only 2 OCX which for convenience I copied to the same folder as the EXE and I had added to the project EVB from that position, in which they were recorded (the recorded versions are in \ Program Files \)

On the last project attached ZIP (v.7.20) I added all the OCX / DLL from their main location (eg. C: Windows \ SysWOW64 \, C: \ Program Files \ CommonFiles \, ...) where are presently registered in the system.
You do not have the required permissions to view the files attached to this post.
gibra
 
Posts: 4
Joined: Tue Nov 04, 2014 8:10 pm

Re: v.7.20 unregister components after Process

Postby napuleone » Sun Nov 16, 2014 7:24 am

same problem to gibra
bath VB6 enterprise SP6 windows XP
napuleone
 
Posts: 2
Joined: Sun Nov 16, 2014 7:19 am

Re: v.7.20 unregister components after Process

Postby napuleone » Sat Nov 29, 2014 7:07 am

you have or do not have the solution?
napuleone
 
Posts: 2
Joined: Sun Nov 16, 2014 7:19 am

Re: v.7.20 unregister components after Process

Postby suibaf » Fri Mar 20, 2015 5:59 pm

I have the same problem!
Yes the application is free but it does not work!!! :lol: :lol: :lol: :lol: :lol:
I don't understand why no fix the problem!
It is no possible to use the application!
suibaf
 
Posts: 2
Joined: Fri Mar 20, 2015 5:54 pm

Re: v.7.20 unregister components after Process

Postby suibaf » Sat Mar 21, 2015 1:14 pm

I Apologize for the previous message.
The problem is solved just virtualize the register!
That's all!
suibaf
 
Posts: 2
Joined: Fri Mar 20, 2015 5:54 pm

Re: v.7.20 unregister components after Process

Postby Enigma » Wed Apr 01, 2015 7:14 am

Yes guys, if you are using ActiveX components in virtual box, then two things should be also done:
1. For each ActiveX file you need to edit the properties and set the option Register As ActiveX
2. Enable registry virtualization, at least for HKEY_CLASSES_ROOT (this registry item should be yellow highlighted - means virtual path, others could be blue highlighted - means real path).
Enigma
Site Admin
 
Posts: 2139
Joined: Wed Aug 20, 2008 2:24 pm


Return to Enigma Virtual Box x86/x64

Who is online

Users browsing this forum: Bing [Bot] and 2 guests