Unable to access registry key

Issues related to Enigma Virtual Box
Post Reply
jmccaleb
Posts: 1
Joined: Mon Dec 16, 2019 5:27 pm

Unable to access registry key

Post by jmccaleb » Mon Dec 16, 2019 5:37 pm

I've worked through everything and gotten as far as the _boxed.exe but when I run it it throws an error:

Unable to access registry key: HKEY_LOCAL_MACHINE/SOFTWARE/Classes/.../AppDataPath

It looks the same as the one in HKEY_CLASSES_ROOT, though I don't know if that means anything. The key is imported from the .reg file, and is virtual, but refers to the C drive location of the app data path. Since this is my first run of the program, I'm not sure if that's right. Any ideas?

Ilya
Posts: 80
Joined: Tue Oct 07, 2014 2:31 am

Re: Unable to access registry key

Post by Ilya » Tue Dec 17, 2019 12:58 pm

Hi,
Seems that are you trying to change system COM registry associations.
You can't do it because only boxed program uses virtual registry, not the system.
You can change system behaviour by writing directly into this registry key if you have access rights of course.

Post Reply