Any questions? Ask us: support@enigmaprotector.com

X64 version... or not??

x64 version issues

X64 version... or not??

Postby mtx-electronics » Mon Oct 22, 2012 3:27 pm

My code is compiled for 32bit OS version and run's perfect under 64bit because of WOW64 emulation... As I understand when I protect my app with 32bit version of Enigma it will not work under 64bit OS, correct?? If this is the case then I would also suppose that x64 version of Enigma will not protect 32bit application?

Will I have to make a new 64bit version of my application to protect it with x64 Enigma?
mtx-electronics
 
Posts: 17
Joined: Wed Oct 10, 2012 8:09 am

Re: X64 version... or not??

Postby Enigma » Mon Oct 22, 2012 4:04 pm

No no, this is common misunderstanding. X64 version of Enigma Protector serves for protection of 64 bit executable files.

For 32 bit executables, you should use x86 version of Enigma. And protected file will be working well on any version of Windows (of course, if unprotected worked there).

Enigma Protector does not limit functionality of protected file. If your file worked well on Win95, then after protection it will be working well there too.
Enigma
Site Admin
 
Posts: 2199
Joined: Wed Aug 20, 2008 2:24 pm


Return to Enigma Protector x64

Who is online

Users browsing this forum: No registered users and 2 guests

cron